re = /^<\d+>([\S]+)\s([\S]+)\saccess-nginx\:\s([\S\.]+)\s\-+\s([\S]+)\s\-\s\-\s\[([\S\s]+)\]\s\"((\\.|[^\"])*)\"\s([\S]+)\s([\S]+)\s\"((\\.|[^\"])*)\"\s\"((\\.|[^\"])*)\"\s\"((\\.|[^\"])*)\"/m
str = '<182>2019-08-05T14:17:25.000000+00:00 hqchweb012 access-nginx: 10.56.40.201 - - - - [05/Aug/2019:14:17:16 +0200] "GET /il/he/customer/account/getminilogindata HTTP/1.1" 200 190 "https://www.nespresso.com/il/he/gifting" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.109" "212.143.212.222, 2.16.187.63, 23.57.69.121"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end