import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]+([\\.-_]?[a-zA-z0-9]+)*)\\@([a-zA-Z0-9]+)([-][0-9a-z]+)?\\.([a-z-]{2,20})(\\.[a-z]{2,3})?$";
final String string = "update@update\n"
+ "mohit.bhagat@B-9com.com\n"
+ "mohit.Bhagat@us.thalesgroup.com\n"
+ "mohit@gmail.com.com.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}