re = /^([a-zA-Z]+([\.-_]?[a-zA-z0-9]+)*)\@([a-zA-Z0-9]+)([-][0-9a-z]+)?\.([a-z-]{2,20})(\.[a-z]{2,3})?$/m
str = 'update@update
mohit.bhagat@B-9com.com
mohit.Bhagat@us.thalesgroup.com
mohit@gmail.com.com.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end