const regex = /^([a-zA-Z]+([\.-_]?[a-zA-z0-9]+)*)\@([a-zA-Z0-9]+)([-][0-9a-z]+)?\.([a-z-]{2,20})(\.[a-z]{2,3})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]+([\\.-_]?[a-zA-z0-9]+)*)\\@([a-zA-Z0-9]+)([-][0-9a-z]+)?\\.([a-z-]{2,20})(\\.[a-z]{2,3})?$', 'gm')
const str = `update@update
mohit.bhagat@B-9com.com
mohit.Bhagat@us.thalesgroup.com
mohit@gmail.com.com.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}