#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*[^0-9@\r\n].*@)"
Local $sString = "1123" & @CRLF & _
"123.123" & @CRLF & _
"123_123" & @CRLF & _
"123@123.123" & @CRLF & _
"123@123.com" & @CRLF & _
"123@abc.com" & @CRLF & _
"123mbc@abc.com" & @CRLF & _
"123mbc@123abc.com" & @CRLF & _
"123mbc@123abc.123com" & @CRLF & _
"123mbc123@cc123abc.c123com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")