package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*[^0-9@\r\n].*@)`)
var str = `1123
123.123
123_123
123@123.123
123@123.com
123@abc.com
123mbc@abc.com
123mbc@123abc.com
123mbc@123abc.123com
123mbc123@cc123abc.c123com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}