import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*[^0-9@\\r\\n].*@)";
final String string = "1123\n"
+ "123.123\n"
+ "123_123\n"
+ "123@123.123\n"
+ "123@123.com\n"
+ "123@abc.com\n"
+ "123mbc@abc.com\n"
+ "123mbc@123abc.com\n"
+ "123mbc@123abc.123com\n"
+ "123mbc123@cc123abc.c123com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}