package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#(.*?)\w+`)
var str = `"This is a #simple text from which we have to perform #regex operation"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}