re = /#(.*?)\w+/
str = '"This is a #simple text from which we have to perform #regex operation"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end