$re = '/#(.*?)\w+/';
$str = '"This is a #simple text from which we have to perform #regex operation"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);