package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,}$`)
var str = `enderson@codaqui.dev
mail@enderson.dev
issonãoéumemail.com.br
issotambémnão`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}