re = /^[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,}$/m
str = 'enderson@codaqui.dev
mail@enderson.dev
issonãoéumemail.com.br
issotambémnão'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end