$re = '/^[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,}$/m';
$str = 'enderson@codaqui.dev
mail@enderson.dev
issonãoéumemail.com.br
issotambémnão';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);