import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\{]*";
final String string = "{ABC}\n"
+ "+ 1\n"
+ "- 1\n\n"
+ "{DEF}\n"
+ "+ 2\n"
+ "- 2\n\n"
+ "{IJK}\n"
+ "+ 3\n"
+ "- 3\n\n"
+ "{LMN}\n"
+ "+ 4 \n"
+ "- 4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}