// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms){[^{]*").unwrap();
let string = "{ABC}
+ 1
- 1
{DEF}
+ 2
- 2
{IJK}
+ 3
- 3
{LMN}
+ 4
- 4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}