import re
regex = re.compile(r"^GROUPS.*?\"(?<name>[^:]+):(?<id>\d+)\"", flags=re.MULTILINE)
test_str = ("GROUPS: [\"group1:44343\", \"group2:23324\", \"group3:66567\"]\n\n"
"USERS: [\"user1:44343\", \"user2:23324\", \"user3:66567\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")