// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^GROUPS.*?"(?<name>[^:]+):(?<id>\d+)""#).unwrap();
let string = "GROUPS: [\"group1:44343\", \"group2:23324\", \"group3:66567\"]
USERS: [\"user1:44343\", \"user2:23324\", \"user3:66567\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}