re = /^GROUPS.*?"(?<name>[^:]+):(?<id>\d+)"/m
str = 'GROUPS: ["group1:44343", "group2:23324", "group3:66567"]
USERS: ["user1:44343", "user2:23324", "user3:66567"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end