using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"string1(?:optionalstring2)?\K\w+";
string input = @"String1OptionalString2WhatWeWant";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}