$re = '/string1(?:optionalstring2)?\K\w+/i';
$str = 'String1OptionalString2WhatWeWant';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);