const regex = /string1(?:optionalstring2)?\K\w+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('string1(?:optionalstring2)?\\K\\w+', 'i')
const str = `String1OptionalString2WhatWeWant`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}