using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^NULL\^";
string input = @"a^NULL^b^c^
e^NULL^NULL^f^
g^h^i^NULL^";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}