$re = '/\^NULL\^/';
$str = 'a^NULL^b^c^
e^NULL^NULL^f^
g^h^i^NULL^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);