package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\^NULL\^`)
var str = `a^NULL^b^c^
e^NULL^NULL^f^
g^h^i^NULL^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}