#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(.*?)`{1,3}(?:.*?)`{1,3}(.*?)"
Local $sString = "some text here" & @CRLF & _
"" & @CRLF & _
"some more" & @CRLF & _
"" & @CRLF & _
"``` some code block" & @CRLF & _
"with markdown" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"some `inline code` too" & @CRLF & _
"" & @CRLF & _
"and more code blocks:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"``` xojo" & @CRLF & _
"This must have three backticks" & @CRLF & _
"flanking it" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"this text isn't matched..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")