$re = '/(.*?)`{1,3}(?:.*?)`{1,3}(.*?)/ms';
$str = 'some text here
some more
``` some code block
with markdown
```
some `inline code` too
and more code blocks:
``` xojo
This must have three backticks
flanking it
```
this text isn\'t matched...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);