import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)`{1,3}(?:.*?)`{1,3}(.*?)";
final String string = "some text here\n\n"
+ "some more\n\n"
+ "``` some code block\n"
+ "with markdown\n"
+ "```\n\n"
+ "some `inline code` too\n\n"
+ "and more code blocks:\n\n\n"
+ "``` xojo\n"
+ "This must have three backticks\n"
+ "flanking it\n"
+ "```\n\n"
+ "this text isn't matched...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}