#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<tr[\s\S]*?class\="left">([^<]*)[\s\S]*?<td>([^<]*)[\s\S]*?viewData\(([^\(]*),"
Local $sString = "<div id="encompass">" & @CRLF & _
" <tr class="lineonoff">" & @CRLF & _
" <td class="xsmall">27</td>" & @CRLF & _
" <td>DATE</td>" & @CRLF & _
" <td class="left">TITLE</td>" & @CRLF & _
" <td>STATUS</td>" & @CRLF & _
" <td><a href="javascript:viewData(ID, '')" class="button purple small"><span>A</span></a></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="lineonoff">" & @CRLF & _
" <td class="xsmall">28</td>" & @CRLF & _
" <td>DATE</td>" & @CRLF & _
" <td class="left">TITLE</td>" & @CRLF & _
" <td>STATUS</td>" & @CRLF & _
" <td><a href="javascript:viewData(ID, '')" class="button purple small"><span>B</span></a></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="lineonoff">" & @CRLF & _
" <td class="xsmall">29</td>" & @CRLF & _
" <td>DATE</td>" & @CRLF & _
" <td class="left">TITLE</td>" & @CRLF & _
" <td>STATUS</td>" & @CRLF & _
" <td><a href="javascript:viewData(ID, '')" class="button purple small"><span>C</span></a></td>" & @CRLF & _
" </tr>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")