// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<tr[\s\S]*?class\="left">([^<]*)[\s\S]*?<td>([^<]*)[\s\S]*?viewData\(([^\(]*),"#).unwrap();
let string = "<div id=\"encompass\">
<tr class=\"lineonoff\">
<td class=\"xsmall\">27</td>
<td>DATE</td>
<td class=\"left\">TITLE</td>
<td>STATUS</td>
<td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>A</span></a></td>
</tr>
<tr class=\"lineonoff\">
<td class=\"xsmall\">28</td>
<td>DATE</td>
<td class=\"left\">TITLE</td>
<td>STATUS</td>
<td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>B</span></a></td>
</tr>
<tr class=\"lineonoff\">
<td class=\"xsmall\">29</td>
<td>DATE</td>
<td class=\"left\">TITLE</td>
<td>STATUS</td>
<td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>C</span></a></td>
</tr>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}