import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr[\\s\\S]*?class\\=\"left\">([^<]*)[\\s\\S]*?<td>([^<]*)[\\s\\S]*?viewData\\(([^\\(]*),";
final String string = "<div id=\"encompass\">\n"
+ " <tr class=\"lineonoff\">\n"
+ " <td class=\"xsmall\">27</td>\n"
+ " <td>DATE</td>\n"
+ " <td class=\"left\">TITLE</td>\n"
+ " <td>STATUS</td>\n"
+ " <td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>A</span></a></td>\n"
+ " </tr>\n"
+ " <tr class=\"lineonoff\">\n"
+ " <td class=\"xsmall\">28</td>\n"
+ " <td>DATE</td>\n"
+ " <td class=\"left\">TITLE</td>\n"
+ " <td>STATUS</td>\n"
+ " <td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>B</span></a></td>\n"
+ " </tr>\n"
+ " <tr class=\"lineonoff\">\n"
+ " <td class=\"xsmall\">29</td>\n"
+ " <td>DATE</td>\n"
+ " <td class=\"left\">TITLE</td>\n"
+ " <td>STATUS</td>\n"
+ " <td><a href=\"javascript:viewData(ID, '')\" class=\"button purple small\"><span>C</span></a></td>\n"
+ " </tr>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}