using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"D:\/prodmix\/[\s\S]+([\s\S]{16,16})";
string input = @"D:/prodmix/Data Cable (USB кабеля)/qdatacabyrle.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}