$re = '/D:\/prodmix\/[\s\S]+([\s\S]{16,16})/m';
$str = 'D:/prodmix/Data Cable (USB кабеля)/qdatacabyrle.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);