re = /D:\/prodmix\/[\s\S]+([\s\S]{16,16})/m
str = 'D:/prodmix/Data Cable (USB кабеля)/qdatacabyrle.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end