$re = '/^\D*(\d)/m';
$str = 'This is a string 1.
This is 1 a string.
This is1 a string.
1This is a string.
1 This is a string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);