#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]) ([01][0-9]|2[0-3]):[0-5]\d)"
Local $sString = "minute/second" & @CRLF & _
"2105-12-21 00:00" & @CRLF & _
"2105-12-21 00:60" & @CRLF & _
"2105-12-21 23:00" & @CRLF & _
"2105-12-21 24:00" & @CRLF & _
"2105-12-21 23:59" & @CRLF & _
"" & @CRLF & _
"year/month/day" & @CRLF & _
"2105-00-00 11:01" & @CRLF & _
"2105-00-01 11:01" & @CRLF & _
"2105-01-00 11:01" & @CRLF & _
"2105-01-01 11:01" & @CRLF & _
"2105-01-12 11:01" & @CRLF & _
"2105-01-13 11:01" & @CRLF & _
"2105-01-20 11:01" & @CRLF & _
"2105-01-29 11:01" & @CRLF & _
"2105-01-30 11:01" & @CRLF & _
"2105-01-31 11:01" & @CRLF & _
"2105-01-32 11:01" & @CRLF & _
"2105-00-31 11:01" & @CRLF & _
"2105-01-31 11:01" & @CRLF & _
"2105-09-31 11:01" & @CRLF & _
"2105-10-31 11:01" & @CRLF & _
"2105-12-31 11:01" & @CRLF & _
"2105-13-31 11:01" & @CRLF & _
"2016-01-01 11:11" & @CRLF & _
"3016-01-01 11:11" & @CRLF & _
"1016-01-01 11:11" & @CRLF & _
"0016-01-01 11:11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")