#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<java_pid>\d+)\s.*java$"
Local $sString = "PID USER PR NI VIRT RES SHR S pctCPU pctMEM cpuTIME COMMAND" & @CRLF & _
"7195 user 20 0 1361m 74m 15m S 25.1 0.3 57:32.41 oneagentos" & @CRLF & _
"7240 api 20 0 14.1g 1.9g 35m S 5.8 8.1 62:42.81 java" & @CRLF & _
"9717 api 20 0 14.1g 1.8g 35m S 3.9 7.8 61:00.56 java" & @CRLF & _
"3882 user1 20 0 1530m 34m 8584 S 1.9 0.1 212:28.61 python"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")