$re = '/^(?<java_pid>\d+)\s.*java$/m';
$str = 'PID USER PR NI VIRT RES SHR S pctCPU pctMEM cpuTIME COMMAND
7195 user 20 0 1361m 74m 15m S 25.1 0.3 57:32.41 oneagentos
7240 api 20 0 14.1g 1.9g 35m S 5.8 8.1 62:42.81 java
9717 api 20 0 14.1g 1.8g 35m S 3.9 7.8 61:00.56 java
3882 user1 20 0 1530m 34m 8584 S 1.9 0.1 212:28.61 python';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);