import Foundation
let pattern = #"^(?<java_pid>\d+)\s.*java$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PID USER PR NI VIRT RES SHR S pctCPU pctMEM cpuTIME COMMAND
7195 user 20 0 1361m 74m 15m S 25.1 0.3 57:32.41 oneagentos
7240 api 20 0 14.1g 1.9g 35m S 5.8 8.1 62:42.81 java
9717 api 20 0 14.1g 1.8g 35m S 3.9 7.8 61:00.56 java
3882 user1 20 0 1530m 34m 8584 S 1.9 0.1 212:28.61 python
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)