#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!\.[^.]*$)\."
Local $sString = "adsdasd.sdfdsfsdf.f43fvev.ASCSDF.sfgsdfssdf.yaml"
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)