$re = '/(?!\.[^.]*$)\./m';
$str = 'adsdasd.sdfdsfsdf.f43fvev.ASCSDF.sfgsdfssdf.yaml';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;