using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<localpart>[^-].*[^-])@(?<domainpart>[^-].*[^-])\..{2,3}$";
string input = @"local__part@domain_part.com
-local__part@-domain_part.com
-local__part@domain_part-.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}