package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<localpart>[^-].*[^-])@(?<domainpart>[^-].*[^-])\..{2,3}$`)
var str = `local__part@domain_part.com
-local__part@-domain_part.com
-local__part@domain_part-.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}