using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9\.]+)";
string input = @"Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}