re = /([A-Za-z0-9\.]+)/m
str = 'Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end