$re = '/([A-Za-z0-9\.]+)/m';
$str = 'Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);