using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"LABEL\d+=\[value=\h";
string input = @"event=RequestLogging foo LABEL1=[value=xyz description=desc1 metadata=[]] LABEL2=[value=abc description=desc2 metadata=[]] LABEL5=[value=def description=desc3 metadata=[]] LABEL6=[value=ghi description= metadata=[]]
bar LABEL3 LABEL4 LABEL5=[value= description= metadata=[]] LABEL6
LABEL5=[value=123 description= metadata=[]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}