$re = '/LABEL\d+=\[value=\h/m';
$str = 'event=RequestLogging foo LABEL1=[value=xyz description=desc1 metadata=[]] LABEL2=[value=abc description=desc2 metadata=[]] LABEL5=[value=def description=desc3 metadata=[]] LABEL6=[value=ghi description= metadata=[]]
bar LABEL3 LABEL4 LABEL5=[value= description= metadata=[]] LABEL6
LABEL5=[value=123 description= metadata=[]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);