import re
regex = re.compile(r"LABEL\d+=\[value=\h", flags=re.MULTILINE)
test_str = ("event=RequestLogging foo LABEL1=[value=xyz description=desc1 metadata=[]] LABEL2=[value=abc description=desc2 metadata=[]] LABEL5=[value=def description=desc3 metadata=[]] LABEL6=[value=ghi description= metadata=[]]\n"
"bar LABEL3 LABEL4 LABEL5=[value= description= metadata=[]] LABEL6\n"
"LABEL5=[value=123 description= metadata=[]]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")