#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\bw(?:eigh)?t\b.{1,25}?\b(?<!\d/)(\d+(?:\.\d+)?)(?!/?\d)\s*(\w+)"
Local $sString = "Weight Measured: 80.7 kg 11/27/1900 24:59:00" & @CRLF & _
"Pulse 64 \F\ Temp 37.3?C (99.1 ?F) \F\ Wt 101.2 kg (223 lb)" & @CRLF & _
"Weight as of 11/11/1900 72.2 kg (159 lb 1.6 oz)" & @CRLF & _
"Resp. rate 16, height 177.8 cm (5' 10"), weight 84.7 kg (186 lb|" & @CRLF & _
"11.2 oz)" & @CRLF & _
"And one extra weight example 100lbs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")