import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\bw(?:eigh)?t\\b.{1,25}?\\b(?<!\\d/)(\\d+(?:\\.\\d+)?)(?!/?\\d)\\s*(\\w+)";
final String string = "Weight Measured: 80.7 kg 11/27/1900 24:59:00\n"
+ "Pulse 64 \\F\\ Temp 37.3?C (99.1 ?F) \\F\\ Wt 101.2 kg (223 lb)\n"
+ "Weight as of 11/11/1900 72.2 kg (159 lb 1.6 oz)\n"
+ "Resp. rate 16, height 177.8 cm (5' 10\"), weight 84.7 kg (186 lb|\n"
+ "11.2 oz)\n"
+ "And one extra weight example 100lbs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}